[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

ThinkPad P72 progress update

Fellow SILUG-ers,

In late November I invested (heavily) in a Lenovo ThinkPad P72 mobile
workstation to replace my deceased ThinkPad W700. Like the W700, the P72
came full of leading (bleeding?) edge features and nuggets, among which
are a pair of 2T NVMe SSDs connected to an Intel RST RAID controller, an
NVIDIA Quadro P5200 video, and a 4K display.

My original plan was to do a forensic bare metal backup of the factory
installed Windows 10 Professional, split the RAID1 configuration, install
F29 on the first SSD and import Windows 10 to a VM running under F29. As
they say, even the best plans go right out the window five minutes after
the battle begins.

As I reported earlier, I ran into trouble almost immediately. The Intel
RST RAID controller cannot be accessed by any commonly known backup
software. After much research, I found that the BIOS supports two access
modes for the Intel RST chip: native RST and an AHCI/SATA emulation mode.
Linux can't see the Windows-only RST mode at all. Linux can see SATA with
mdadm, but there is no common ground between the two. Fedora really really
wants to use mdadm. So if I want to installed a native F29 on this system,
I have to give it a SATA hard drive. The RAID1 and RST mode must go.

Bear in mind that when I flip that switch in the BIOS, the factory
installed Windows 10 Professional will vaporize and I will be left with
two 2T NVMe SSDs running in emulated SATA mode. This will certainly be
slower than the native NVMe interface, but I really have no other choice.

To see if F29 would even run on the P72, I tried booting it from a DVD
containing the F29 Workstation ISO image. That failed. I made a thumb
drive with the same ISO image, and that too failed. In each case I got a
black screen after the GNOME display manager started. Research said a
change was needed in a BIOS Display setting for the P5200 chip. I had to
change a [HYBRID] Windows-only speed hack over to [DISCRETE] so F29 could
actually see the true PCI interface.

I hit F10 save and rebooted into runlevel 3, which it (miraculously?) just
did. For 126 seconds. Then it threw an error which I promptly transcribed
and sent off to the thinkpad_acpi maintainer:


I got this error on my new Lenovo ThinkPad P72 mobile workstation just 126
seconds after booting the Fedora 29 Workstation live DVD from a thumb
drive in runlevel 3 (text only). This is a manual transcription of the
screen output:

Fedora 29 (Workstation Edition)
Kernel 4.10.16-300.fc29.x86_64 on an x86_64 (tty1)

localhost login: [    41.103546] L1TF CPU bug present and SMT on, data
leak possible. See CVE-2018-3646 and
https://www.kernel.org/doc/html/latest/admin-guide/l1tf.html for details
[root@localhost ~]# ls -al
total 48
dr-xr-x---.  3 root root  4096 Feb  8 22:31 .
dr-xr-xr-x. 18 root root  4096 Feb  8 22:31 ..
-rw-------.  1 root root 12502 Oct 24 20:03 anaconda-ks.cfg
-rw-r--r--.  1 root root    18 Jul 15 2010  .bash_logout
-rw-r--r--.  1 root rot    176 Jul 15 2010  .bash_profile
-rw r--r--.  1 root root   176 Jul 15 2010  .bashrc
drwxr-xr-x.  3 root root  4096 Feb  8 22:31 .cache
-rw-r--r--.  1 root root   100 Jul 15 2010  .cshrc
-rw-r--r--.  1 root root   129 Jul 15 2010  .tchrc
[root@localhost ~]# cd /home/liveuser
[root@localhost liveuser]# ls -al
drwx------.  4 liveuser liveuser 4096 Feb  8 22:31 .
drwxr-xr-x.  3 root     root     4096 Feb  8 22:31 ..
-rw-r--r--.  1 liveuser liveuser   10 Oct  8 09:41 .bash_logout
-rw-r--r--.  1 liveuser liveuser   10 Oct  8 09:41 .bash_profile
-rw-r--r--.  1 liveuser liveuser   10 Oct  8 09:41 .bashrc
dr-xr-xr-x.  3 liveuser liveuser 4096 Feb  8 22:31 .config
dr-xr-xr-x.  4 liveuser liveuser 4096 Oct 24 19:50 .mozilla
[root@localhost liveuser]# df -h
Filesystem           Size  Used Avail Use% Mounted on
devtmpfs              32G     0   32G   0T /dev
tmpfs                 32G  4.0K   32G   1% /dev/shm
tmpfs                 32G  1.3M   32G   1% /run
tmpfs                 32G     0   32G   0% /sys/fs/cgroup
/dev/sda1            1.0G  1.0G     0 100% /run/initramfs/live
/dev/mapper/live-rw  6.4G  5.2G  1.2G  83% /
tmpfs                 32G  4.0K   32G   1% /tmp
vartmp                32G     0   32G   0% /var/tmp
tmpfs                6.3G     0  6.3G   0% /run/user/0
[root@localhost liveuser]# [  126.960811] thinkpad_acpi: unhandled HKEY
event 0x6031
[  126.960872] thinkpad_acpi: please report the conditions when this event
happened to ibm-acpi-devel@lists.sourceforge.net


I haven't broken the RAID yet because I still have some serious backing up
to do. Once I make the change from HYBRID to DESCRETE, all is lost and I'm
at square zero.

Stay tuned.

Robert G. (Doc) Savage
Fairview Heights, IL

"Perfection is the enemy of good enough."
          -- Admiral of the Fleet Sergei G. Gorshkov

To unsubscribe, send email to majordomo@silug.org with
"unsubscribe silug-discuss" in the body.